
Лабораторное занятие 3.2  

РАБОТА С ПРОГРАММНОЙ СРЕДОЙ СОЗДАНИЯ ВИРТУАЛЬНЫХ 
ПРИБОРОВ LABVIEW. 

 Цель работы:  

Привить умение решать задачи моделирования, позволяющие 
прогнозировать свойства и характеристики аппаратов, использовать 
информационные технологии при диагностике устройств 
электротехнического и электроэнергетического оборудования, составлять 
программы испытаний и отчеты по результатам испытаний, использовать 
современные достижения науки и техники. 

Овладеть навыками разработки программ и методик проведения 
испытаний электротехнических и электроэнергетических устройств и систем, 
навыками разработки и внедрения современных технологий на объектах 
электроэнергетики, современными измерительными и компьютерными 
системами и технологиями в области проверки технического состояния и 
остаточного ресурса оборудования и организации профилактических 
осмотров и текущего ремонта, современными компьютерными технологиями 
при составлении программ испытаний; современными измерительными 
системами проведения испытаний электрооборудования и аппаратов 
электроустановок 

 

  Выполнить:практическую часть с оформлением отчета. 

 
ПРАКТИЧЕСКАЯ ЧАСТЬ: СОЗДАНИЕ ВИРТУАЛЬНОГО ПРИБОРА 

(VI), ГЕНЕРИРУЮЩЕГО СИГНАЛ И ОТОБРАЖЕНИЕ ЭТОГО 
СИГНАЛА НА ГРАФИКЕ 

 

Методика выполнения работы 

1. Открытие нового ВП на базе шаблона. 

1. Открыть диалог с помощью значка  на рабочем столе или через 
команду Программы главного меню Пуск, показанный на рис. 1. 

2. На диалогеLabVIEW(рис. 1) щелкните мышью на кнопке 
New(Новый), для того чтобы открыть диалогNew. 



 
 

Рис. 1. Диалоговое окно программы LabVIEW 
3. Выберите из списка Createnew (Создать новый) 

VIfromTemplate>>Tutorial (Gettingstarted)>>GenerateandDisplay(ВП по 
шаблону>>Обучение (Введение)>>Генерация и Отображение), показанный 
на рис. 2. 

 
 

Рис. 2. Диалоговое окно New 
Обратите внимание, что предварительный вид шаблона ВП 

появляется в разделе Frontpanelpreview(Предварительный просмотр 
Лицевой панели) и Blockdiagrampreview(Предварительный просмотр блок-
диаграммы).  

4. Нажмите на кнопку ОК, для того чтобы открыть шаблон.  
Также можно открыть требуемый шаблон при помощи двойного 
щелчка левой кнопки мыши на названии этого шаблона в списке 
CreateNew. 

5. Изучите лицевую панель ВП. Интерфейс пользователя или лицевая 
панель появляется в окне с серым фоном и содержит управляющие элементы 
и индикаторы элементы отображения. Название окна лицевой панели 
указывает на то, что это лицевая панель ВП GenerateandDisplay. 



Обратите внимание, если лицевая панель невидима, то ее можно 
вызвать, выбрав команду меню Window » ShowFrontPanel(Окно » 
Показать Лицевую Панель). 

6. Изучите блок-диаграмму ВП. Блок-диаграмма появляется в окне 
с белым фоном и содержит ВП и структуры, служащие для 
управления   элементами   отображения    на   лицевой    панели. 
Название окна блок-диаграммы указывает на то, что это блок 
диаграмма ВП GenerateandDisplay. 

Обратите внимание, если блок-диаграмма невидима, то ее можно 
вызвать, выбрав команду меню Window » ShowBlockDiagram (Окно » 
Показать Блок Диаграмму). 

7. На лицевой панели нажмите кнопку Run(Пуск) . 

8. Остановите ВП, нажав на кнопку STOP на лицевой 
панели. 

 

2. Добавление элемента управления на лицевую панель ВП. 

Элементы   управления   на   лицевой   панели   эмулируют   органы 
управления реального прибора и служат для передачи данных на блок 
диаграмму ВП. Многие измерительные приборы имеют ручки настройки, 
вращая которые можно менять значение настройки  (входной величины). 

Выполните следующие действия, чтобы добавить ручку настройки на 

лицевую панель. 

Примечание.В ходе выполнения упражнений, Вы можете отменить 
внесенные Вами в последнее время изменения, используя команду меню      
Edit »Undo (Редактирование »Отмена) или нажав комбинацию клавиш <Ctrl-
Z>. 

1. Если палитра Controls(Элементы лицевой панели), показанная на 
рис.3 невидима, то ее можно вызвать, выполнив команду меню Window » 
ShowControlsPalette(Окно »Показать Палитру Элементов Лицевой Панели) 
или правой кнопкой мыши на лицевой панели. 

 
 



Рис. 3. Палитра Controls(Элементы Лицевой Панели) 
 
2. Перемещайте   курсор   над   иконками   на   палитре   Controls, 

остановитесь и раскройте палитру NumericControls(Цифровые 
Элементы). 

Обратите внимание, что когда  перемещается курсор над иконками 
палитры Controls, имя вложенной палитры (подпалитры) появляется над 
изображениями иконок всех подпалитр. Кода курсор задерживается над 
иконкой подпалитры, элемента управления или индикатора, то на 
отведенном над иконками месте появляется соответствующее полное 
название. 

3. Нажмите   на   иконку   NumericControls,   чтобы   открыть  эту 
подпалитру. 

4.Выберите   элемент   управления   Knob   (Ручка   Настройки) на 
палитре NumericControlsи поместите ее на лицевую панель слева от 
графика осциллограммы. Она будет использована для задания амплитуды 
сигнала. 

5. Выполните команду меню File » SaveAs (Файл » Сохранить как)   
и сохраните этот ВП под именем  Acquiring  а Signal. viв удобной папке. 

3. Изменение типа сигнала. 

На блок-диаграмме находится голубая иконка   с ярлыком 
SimulateSignal(Моделирование Сигнала). Эта иконка представляет Экспресс 
ВП SimulateSignalExpressVI. SimulateSignalExpressVInoумолчанию 
имитирует генератор синуса. Выполните следующие действия, чтобы 
поменять генератор синуса на генератор пилообразного сигнала. 

1. Активизируйте   блок   диаграмму,   выполнив   команду   меню 
Window » ShowBlockDiagramили щелкнув мышью на окне блок 
диаграммы. 

Обратите внимание на SimulateSignalExpress ВП, показанный выше. 
Express ВП - это элемент блок схемы, который можно сконфигурировать для 
выполнения типовой задачи измерения и обработки сигнала при помощи 
соответствующего диалога. SimulateSignalExpress ВП программно эмулирует 
генератор сигнала, базируясь на сконфигурированных настройках. 

2. Щелкните правой кнопкой мыши на SimulateSignalExpress ВП и 
выберите команду Properties (Свойства) из всплывающего меню для запуска 
диалога ConfigureSimulateSignal (Конфигурирование Моделируемого 



Сигнала). 

3. Выберите Sawtooth (Пилообразный Сигнал) из всплывающего 
меню Signaltype (Тип сигнала). 

Обратите внимание на то, что осциллограмма сигнала в секции 
ResultPreview (Предварительный Просмотр Результата) изменилась и 
показывает пилообразный сигнал. Диалог ConfigureSimulateSignal должен 
выглядеть, как на рис. 4. 

 

 

 
Рис. 4. Диалоговое окно ConfigureSimulateSignal(Конфигурирование 

Моделируемого Сигнала) 
4. Нажмите   кнопку   OK,   для   того   чтобы   применить   текущие 

настройки и закрыть диалог ConfigureSimulateSignals. 
5. Переместите курсор к нижней границе иконки ВП SimulateSignal 

Express VI. 

6. Когда   курсор   измениться   на   двустороннюю   стрелку,   как 

показано на рис.  , нажмите левую кнопку мыши и, удерживая ее, 
потащите нижнюю границу Express VI (Экспресс ВП) вниз до тех 
пор, пока не появится вход Amplitude (Амплитуда). Обратите внимание на 
то, каким образом «растягивается» иконка  SimulateSignalExpress VI, для того 



чтобы появился новый вход. Так как вход Amplitude появляется на блок-
диаграмме, то можно настраивать амплитуду пилообразного сигнала 
непосредственно на блок-диаграмме. Нарис. 4 Amplitude - 
однаизнастроекдиалогаConfigure Simulate Signals. 

Таким образом, если вход (такой как Amplitude) появляется в 
конфигурационном диалоге и на блок-диаграмме, то его можно настраивать в 
обоих местах. 

 

4. Соединение объектов на блок-диаграмме. 

Для того чтобы при помощи ручки настройки Knob можно было менять 
амплитуду генерируемого сигнала, необходимо соединить два объекта на 
блок-диаграмме. Выполните следующие действия  для подсоединения ручки 
настройки Knob к входу Amplitude ВП SimulateSignalExpress VI. 

1. Перемещайте курсор над терминалом (терминал служит для 
представления элемента лицевой панели на блок-диаграмме) Knob до тех пор, 
пока не появится инструмент позиционирования. Обратите внимание на то, 
что когда выбирается инструмент позиционирования (Positioningtool), курсор 

меняет свой вид на стрелку, как это показано на рис. . Инструмент 

позиционирования  служит для того, чтобы менять положение объекта на 
блок-диаграмме или менять размеры объекта. 

2. Щелкните на терминал Knob для того, чтобы его выбрать и затем 
перетащите его левее ВП SimulateSignalExpress VI. Убедитесь, 

что терминал Knob находится внутри рамки цикла .Видно, что 
терминалы служат для передачи входной и выходной информации между 
лицевой панелью ВП и его блок-диаграммой. 

3. Отмените  выделение  терминала  Knob,   щелкнув  мышью на 
любом пустом месте на блок-диаграмме. 

4. Перемещайте курсор над стрелкой терминала Knob, как это 

показано на рис. . 

Обратите внимание, как курсор меняет свой вид на катушку с 

проводом, когда выбирается инструмент катушка (Wiringtool) . 



Инструмент катушка служит для соединения объектов на блок-диаграмме 
между собой. 

Обратите внимание, что курсор не будет менять инструмент с одного 
на другой до тех пор, пока объект выделен. 

5. Когда  появится   инструмент  катушка,   щелкните   на  стрелку 
терминала Knob и затем переместите катушку до иконки ВП 
SimulateSignalExpressVI и щелкните на входе Amplitude, как 
показано на рис. ниже, соединив, таким   образом,   два объекта. 

 

Обратите внимание, что между двумя объектами на блок-диаграмме 
появился провод, который их соединяет. Поток данных будет передаваться от 
терминала к ВП по этому проводу. 

6. Выберите команду File » Save, для того чтобы сохранить этот 
ВП. Сохраните ВП под именем AcquiringaSignal. VI. 

5. Запуск ВП. 

Запуск ВП приводит к выполнению созданного приложения. 
Выполните следующие действия  для запуска ВП AcquiringaSignalVI. 

1.Откройте лицевую панель ВП, выбрав команду меню Window » 
ShowFrontPanel или щелкнув мышью на окне лицевой панели. 

Внимание, для  быстрого  переключения  между лицевой  панелью  ВП  
и  его блок-диаграммой можно использовать комбинацию клавиш <Ctrl-E>. 

2. Нажмите на кнопку Run . 

3. Переместите курсор над ручкой настройки Knob. Курсор меняет свой   

вид на изображение руки , это означает, что выбран инструмент 
Управление (Operatingtool). Инструмент управление служит для того, чтобы 
менять текущие значения элементов управления или выделять текст, 
отображаемый   элементом управления на лицевой панели. 

4. Используя инструмент управление вращайте ручку настройки 
Knob для задания амплитуды пилообразного сигнала. Амплитуда сигнала 
меняется при вращении Knob, одновременно изменяются пределы на у - 
шкале осциллограммы, т.к. по умолчанию для графика осциллограммы 
включен режим автошкалирования. 



Для того чтобы показать, что ВП запущен и выполняется, служит  
кнопка Run, которая во время выполнения ВП меняет свой цвет на черный 

. Во время выполнения ВП редактирование лицевой панели или блок-
диаграммы невозможно. 

5. Нажмите на кнопку STOP длязавершения работы ВП. 

Обратите внимание, что рядом с кнопкойRun помещается кнопка 

AbortExecution (Экстренное Прерывание Выполнения ВП). Кнопка 
AbortExecutionне всегда завершает работу ВП правильным способом. 
NationalInstruments рекомендует останавливать созданный ВП при 
помощи кнопки STOPна лицевой панели ВП.Используйте кнопку 
AbortExecutionтолько в случае, когда обычная остановка ВП при помощи 
кнопки STOPневозможна из-за ошибок, допущенных во время создания ВП. 

6. Изменение сигнала. 

Выполните следующие действия, для того чтобы промасштабировать 
сигнал программным образом и вывести результат на график 
осциллограммы. 

1. На блок-диаграмме используйте инструмент позиционирования, 
для того чтобы выделить проводник. Осуществите двойной щелчок левой 
кнопки мыши на проводнике, соединяющем ВП SimulateSignalExpressVI и 
терминал осциллограммы WaveformGraph, как это показано на рис. 

. 

2. Для того чтобы удалить этот проводник нажмите кнопку <Delete> на 
клавиатуре. 

3. Если палитра функций Functionspalette (рис.5) не видна, 
ее можно вызвать, выбрав команду меню Window » 
ShowFunctionsPaletteилиправой кнопкоймыши на блок-диаграмме. 

 

Рис. 5. ПалитраFunctions (Функции) 



 

4. Выберите Экспресс ВП ScalingandMappingExpressVI, 

показанный на рис. , из 
подпалитрыArithmetic&Comparison(Арифметические операторы и 
операторы Сравнения). Поместите этот ВП на блок-диаграмму внутрь 
структуры цикла, между ВП SimulateSignalExpressVI и терминалом 
WaveformGraph. Если между ними на блок-диаграмме нет достаточно 
места, то можно при помощи мыши передвинуть терминал 
WaveformGraphвправо. Как только ВП ScalingandMappingExpressVI 
размещен, на блок-диаграмму автоматически будет активизирован диалог 
ConfigureScalingandMappingдля настройки этого Экспресс ВП. 

5. Настройте величину коэффициента масштабирования, введя 10 в 
текстовое поле Slope(m) (Угловой коэффициент). Диалог 
ConfigureScalingandMappingдолжен выглядеть так, как показан на рис. 6. 

6. Нажмите кнопку OK, для того чтобы применить сделанные 
настройки и закрыть диалог ConfigureScalingandMapping. 

7. Поместите курсор над стрелкой выхода SawtoothВП Simulate 

SignalExpressVI. 

 

 

Рис. 6.ДиалоговоеокноConfigure Scaling and Mapping 

 

8. Когда курсор поменяет свой вид на катушку, щелкните на эту 
стрелку и затем щелкните на стрелку ввода SignalsВП 
ScalingandMappingExpressVI, как это показано на рис. 



, для того чтобы соединить эти объекты 
вместе. 

9. Используя, инструмент катушка, соедините выход 
ScaledSignal(Масштабированный Сигнал) ВП ScalingandMappingExpressVIи 
терминал WaveformGraph. Провода   на   блок-диаграмме   соединяют   
Экспресс   ВП   и терминалы. Стрелки на Экспресс ВП показывают 
направление, по которому передаются данные по проводам. 

После сделанных изменений блок-диаграмма выглядит, как 
показано на рис. 7. 

 

Рис. 7.Блок-диаграммаВП Acquiring a Signal 

 

10. Сохраните ВП, выполнив команду меню File » Save. 

   7.  Вывод на график двух сигналов. 

Для того чтобы сравнить сигнал, генерируемый при помощи ВП 
SimulateSignalExpressVI, и модифицированный при помощи ВП 
ScalingandMappingExpressVI сигнал на одном и том же графике 
используется функция MergeSignals (Объединение Сигналов).  

Выполните следующие действия, для того чтобы отобразить на графике 
сразу два сигнала. 

1. Поместите курсор над стрелкой выхода SawtoothВП Simulate 
SignalExpressVI. 

2. Используя, инструмент катушка, соедините выход Sawtoothи 



терминал WaveformGraph. 

Функция MergeSignals, показанная на рис. , появится в месте 
соединения двух проводов вместе. Эта функция принимает два различных 
сигнала и комбинирует их вместе таким образом, чтобы их можно было 
одновременно отобразить на одном графике. После изменений блок-
диаграмма выглядит, как показано на рис. 8. 

 

Рис. 8. Блок-диаграмма с функцией MergeSignals 

3. Сохраните ВП, используя команду меню File » Saveили нажав 
комбинацию клавиш <Ctrl-S>. 

4. Вернитесь на лицевую панель ВП, запустите ВП и повращайте 
ручку настройки Knob. 

График осциллограммы теперь выводит два сигнала (исходный 
пилообразный и промасштабированный). Максимальное значение у - оси 
меняется автоматически (в 10 раз больше, чем текущее значение Knob, 
согласно установленному угловому коэффициенту ВП 
ScalingandMappingExpressVI). 

5. Нажмите кнопку STOP. 

8. Конфигурирование элемента управления Knob. 

В созданном ВП, ручка настройки Knob позволяет менять амплитуду 
пилообразного сигнала, поэтому лучше поменять ярлык (название) этого 
элемента на Амплитуда, для того чтобы на лицевой панели ВП было сразу 
ясно, за что отвечает данная ручка настройки. 

Выполните следующие действия, чтобы сконфигурировать внешний 
вид элемента управления лицевой панели ВП. 

1. Щелкните правой кнопкой мыши на элементе управления Knob и 



из всплывающего меню выберите Properties(Свойства), для того чтобы 
вызвать диалог KnobProperties. 

2.  В секции Label(название) на странице с закладкой Appearance 
(Внешний Вид) удалите название Knobи введите новое название 
- Амплитуда. Диалог KnobProperties выглядит, как показано на рис. 9. 

 

Рис. 9. Диалоговое окно KnobProperties 

3. Щелкните на закладке Scaleсоответствующей страницы свойств и в 
секции ScaleStyle(Стиль Шкалы) отметьте RumpVisible(Линейная шкала 
Видима). Элемент управления лицевой панели ВП сразу воспринимает 
внесенные изменения. 

4. Нажмите  кнопку  ОК,  для  того  чтобы   применить  текущую 
конфигурацию и закрыть диалог KnobProperties.  

5. Сохраните ВП. 

Внимание, для отмены сделанных изменений в ходе конфигурирования 
свойств, добавления/удаления объектов, можно использовать команду меню 
Edit » Undo или комбинацию клавиш <Ctrl-Z>. 

6. Поэкспериментируйте с другими свойствами ручки управления, 
используя   диалог   KnobProperties.   Например,   попробуйте поменять   
цвет   маркера   MarkerTextColor   (Цвет   Текста Маркера),   щелкнув 
мышью  на  colorbox   (выбор  цвета) на странице с закладкой Scale. 

7. Нажмите кнопку Cancel, для того чтобы отменить внесенные 
вами изменения при конфигурировании внешнего вида ручки 
настройки и закрыть диалог (если эти изменения разработчика устраивают, 
можно нажать на кнопку ОК, для того чтобы их применить). 



9. Конфигурирование графика. 

График выводит на экран осциллограммы двух сигналов. Для того 
чтобы обозначить, какая именно из кривых графика представляет 
осциллограмму исходного сигнала, а какая отмасштабированного требуется 
настроить элемент лицевой панели - график. 

Выполните следующие действия, для того чтобы сконфигурировать 
внешний вид графика на лицевой панели ВП. 

1.Поместите   курсор   над   верхней   границей   легенды   кривых 
графика. Пока, несмотря на то, что на графике отображаются две 
кривые, легенда содержит описание только одной из них. 

2. Когда курсор изменит свой вид на двустороннюю стрелку, как 
показано на рис. 10, нажмите левую кнопку мыши и потащите верхнюю 
границу легенды кривых графика, пока не появится имя  второй кривой. 

 

Рис. 10. Увеличение легенды кривых графика 

3. Щелкните правой кнопкой мыши на графике и выберите команду 
Properties  из  всплывающего  меню,  для  того  чтобы  вызвать  диалог 
GraphProperties (Свойства Графика). 

4. На   странице   свойств   с   закладкой   Plots   (Кривые   Графика) 
выберите Sawtooth из выпадающего списка. Щелкните мышью на 
LineColorcolorbox (Цвет Линии выбор цвета), для того чтобы вызвать окно 
выбора цвета. Выберите новый цвет для линии. 

5.Выберите Sawtooth (Scaled) из выпадающего списка. 

6. Отметьте опцию Don'tusewaveformnameforplotnames (He 
использовать имена осциллограмм для имен кривых графика). 

7.В текстовом поле Name (имя) удалите текущее название кривой 
графика  и  поменяйте  его  на   Масштабированный Пилообразный Сигнал. 



8. Нажмите на кнопку ОК, для того чтобы применить текущую 
конфигурацию и закрыть диалог GraphProperties. 

9. Поэкспериментируйте с другими свойствами графика, используя 
диалог   GraphProperties. Например, попробуйте поменять режим  
автошкалирования   графика,    который    находится    на странице с 
закладкой Scales (Шкалы). 

10. Нажмите кнопку Cancel, для того чтобы отменить внесенные   
изменения.  Если  необходимо  сохранить  эти  изменения, нажмите кнопку 
ОК. 

11. Сохраните, а затем закройте ВП. Скопируйте данные на дискету для 
оформления отчета. 

Контрольные вопросы 

1. Что представляет собой интегрированный пакет LabVIEW? 
2. Назначение и состав палитры инструментов. 
3. Назначение и состав палитры Средств Управления. 
4. Назначение и состав палитры Функций. 
5. Что представляет собой блок-диаграмма в LabVIEW?  

 
Оформление отчета 

 

Отчет по лабораторной работе должен содержать: 

1. Титульный лист 
2. Цели работы 
3. Краткие теоретические сведения в виде ответов на контрольные 

вопросы.  
4. Результаты лабораторной работы (графики, таблицы, значения 

параметров измеренных в процессе работы). 
5. Необходимые расчеты (если они оговариваются в практической части 

лабораторной работы). 
6. Выводы по работе (что получено в процессе работы, почему получены 

данные результаты и т. д.). 
7. Отчет для защиты представляется преподавателю в отпечатанном или 
электронном виде.  


